OseComm32 User Manual

This user manual explains the control of the OseComm32 application.

More information can be found at www.opticon.com


OseComm32 Description

Description

OseComm is a new communication protocol for the Opticon Hand hel held terminals and can be used as a replacement for the NetO protocol. The OseComm protocol supports more then only file transfers. All options that are supported by the OseComm protocol are called tasks. All of these task are controlled by the PC. The protocol can handle a range of task in one communication run.

Supported OseComm protocol tasks:

  • File transfer from PC to terminal
  • File transfer from terminal to PC
  • Transfer local PC time and date to terminal
  • Receive terminal time and date
  • Receive terminal application version number
  • Receive terminal OS version number
  • Receive terminal file listing
  • Delete terminal files (from OseComm protocol version 1.01)

Help

When more help is needed then contact the Opticon support department support@opticon.com

License

This software is copyright © 2010, Opticon Sensors Europe B.V.
All Rights reserved.

This software may only be used on installations that include hardware (such as bar code readers) directly or indirectly supplied by Opticon Sensors Europe B.V.

The physical media and physical documentation (if any) are warranted for one year after purchase. The liability of Opticon Sensors Europe B.V. is limited to replacement of defective media or documentation.

Opticon Sensors Europe B.V. does not warrant that this software is error free, or that it meets any user's particular standards, requirements, or needs.

Opticon Sensors Europe B.V. will in no event be liable for any direct, indirect, consequential or incidental damages arising out of use of this software.


Communication settings

The main part of the Communication Settings have to do with the RS232 settings. These settings should match the terminal and the cradle settings. The other options for an RS232 that cannot be set with the OseComm32 application are:

  • Byte size (8 bits)
  • Parity (None)
  • Stopbits (1 stopbit)

Serial port

Serial port shows all available serial ports that are available on the PC. It also shows the serial ports that are in use by other applications. Select in the combo box the serial port to which the handlheld terminal(s) is/are connected.

Communication Speed

With the Communication speed option the speed of the selected serial port is set. The speed selected must match the baudrate that is set on the terminal and cradle. The default value for the speed is "115200" baud.

IrDA Adapter

The OseComm32 application support several IrDA adapters. The IrDA adapter settings are needed by IrDA devices (Cradles) that support auto baudrate. Most of the Opticon cradles that support auto baudrate will use the litelink compatible IrDA adapter. The Litelink IrDA adapter is the default IrDA adapter.

Protocol type

The protocol type is the way the communication works. The OseComm32 application support 3 different types. Continouos communication protocol after a successful or a failed communication the protocol will continue to poll to look for another terminal.

"X Times success" protocol is stopped after a x times successful communication.

"X Times no answer" protocol is stopped after a x times no answer on a poll command.

Run protocol at start

Protocol immediatly started when the application is started.

Run minimized at start

Window is minimized when the OseComm32 application is started.


Protocol tasks

In the protocol tasks propery screen the communication tasks for a session can be controlled. the OseComm32 application holds the following protocol tasks.

  • Get OS Version
  • Get Application Version
  • Get Time / Date
  • Set Time / Date
  • Receive file(s)
  • Transmit file
  • List file(s)
  • Delete file(s)

Taks list

Show all the set communication tasks. The communication session will start from the top an go down until the last task has been completed.

Task group

Here the task can be selected to add.

Edit task

Some of the task that needed additional user input before it is added to the task list can be edited when selected.

Delete task

Deletes the current selected task from the task list.

Delete all tasks

Deletes all the tasks from the task list.

Get Application version

Get the application version of the current connected terminal.

Get Time / Date

Get the time and date from the terminal. A format option needs to be set to show how the downloaded time and date will show in the status log.

Set Time / Date

Transfer the local PC Time and Date to the connected terminal.

Receive file(s)

Get the local file(s) from the terminal. The file can be a specific file or more files when the filename is based on a filter. The specific drive can be selected when the terminal has multiple drives. Continue when not available option wil result in a communication session when the requested file not available on the terminal the protocol will proceed with the next task in the task list. The download folder is the folder where the received files from the terminal will be stored. The download type will set how the file is being stored. Append file will append the downloaded file to an already existing file. Overwrite file the downloaded file overwrite the existing file. New extension will result when a file already exist the extension is changed to "000" for the first one will increase til "999". When "999" is reached and another file with the same filename is downloaded an error will be shown. New file will add numbers to the filename until 9999 is added after this an error will be reported. The extension with the New file option is not altered.

Transmit file

With the tranmit file option one or more files can be selected to load into the connected terminal. When multiple files are are set every file will get their own task in the task list. A drive can be selected per file. Transmit file also holds the option continue when not available, this result when the file is not available on the PC the protocol continueus with the next task.

List file(s)

Does a file listing in the same way as the "DIR" command in a dos environment does. The List file(s) options supports a sepecific filename or a filter. The file listing can be done on a specific drive when available in the terminal.

Delete file(s)

Deletes files in the terminal. The Delete files options supports a sepecific filename or a filter. The deletion of files can be done in a specific driver if the terminal supports this. This function is supported from OseComm protocol version 1.01.